Blog → Post


(TIP) (How to Fix) 'The following packages will be kept back'
by @admin, april 04, 2019, 12:10am utc

"The following packages will be kept back"

If during a $ sudo apt-get upgrade you see a message that "The following packages will be kept back" followed by one or more package names, it means that the upgrade would require another package to be deleted, or a new package to be installed so that yours can be installed.

To actually complete the install, run:

sudo apt-get --with-new-pkgs upgrade

This will first alert you to what other packagers need to be deleted or installed to get your desired one installed.

See more here.

tags: All users, Tips
RSS Feed
      Privacy Policy
Footer done in Inkscape
© 2018-2020 La Vojo. All Rights Reserved.